Unable to access Ecodesign portal

Incident Report for driveswebapps

Resolved

Between 12:06 AM and 06:36 AM UTC on 14 September 2026, Our Ecodesign portal experienced technical issues and users were not able to access portal. This issue has been resolved now.
Posted Sep 14, 2026 - 07:37 UTC

Investigating

Starting from 12:06 AM on 14 September 2026 UTC, Ecodesign portal is experiencing technical issues and users are not able to access portal. We are working on bringing the system back online as quickly as possible.
Posted Sep 14, 2026 - 01:15 UTC
This incident affected: ABB EcoDesign (Portal, Backend Services).